Fórum PiR2
Gostaria de reagir a esta mensagem? Crie uma conta em poucos cliques ou inicie sessão para continuar.

MAIOR e MENOR no visualg

2 participantes

Ir para baixo

MAIOR e MENOR no visualg Empty MAIOR e MENOR no visualg

Mensagem por isac_pc Ter Jun 25 2019, 08:04

Olá pessoal estou tendo ua dúvida de lógica aqui! Estou querendo executar um código que me dê o maior e o menor valor digitado, só que para realizar o pedido do maior valor digitado foi tranquilo. 

algoritmo "maiormenor"
var
cont,v1,numx:inteiro
inicio
      cont<-1
      enquanto (cont<=5) faca
               escreval("Digite o",cont,"º valor:")
               leia(v1)
                       se (v1>numx) entao
                       numx<-v1
                       fimse
               cont<-cont+1


      fimenquanto


      ESCREVAL("O maior valor digitado foi: ",numx)




fimalgoritmo


Pois eu entendo que quando meu valor inserido for maior que minha variável vazia, minha variável passa a ser esse valor, mas não consegui usar a mesma lógica para o menor valor. Então eu pensei que seria a mesma coisa para o menor valor, Quando meu valor inserido for menor que minha variável vazia, minha variável passa ser esse valor, mas não, desse jeito ela sempre me retorna 0:

algoritmo "maiormenor"
var
cont,v1,numy:inteiro
inicio
      cont<-1
      enquanto (cont<=5) faca
               escreval("Digite o",cont,"º valor:")
               leia(v1)
                       se (v1
                       numy<-v1
                       fimse
               cont<-cont+1


      fimenquanto


      ESCREVAL("O menor valor digitado foi: ",numy)


fimalgoritmo

Depois, não funcionando esse jeito, ajeitei o código e consegui:


algoritmo "maiormenor"
var
cont,v1,numy:inteiro
inicio
      cont<-1
      enquanto (cont<=5) faca
               escreval("Digite o",cont,"º valor:")
               leia(v1)

                       se (cont=1) entao
                  numy<-v1
                  senao
                       se   (v1
                       numy<-v1
                       fimse
               fimse
               cont<-cont+1
      fimenquanto


      ESCREVAL("O menor valor digitado foi: ",numy)
fimalgoritmo



Pois para mim faz sentido que quando o contador está na primeira vez e única até o momento, numy recebe esse valor, se não quando o valor digitado for menor que minha variável vazia, ela recebe esse valor.OK

Mas a dúvida é: Por quê eu não consegui usar a mesma lógica que fiz para retirar o maior valor com o menor valor?
isac_pc
isac_pc
Recebeu o sabre de luz
Recebeu o sabre de luz

Mensagens : 102
Data de inscrição : 15/05/2016
Idade : 22
Localização : Juazeiro do Norte, CE Brasil

Ir para o topo Ir para baixo

MAIOR e MENOR no visualg Empty Re: MAIOR e MENOR no visualg

Mensagem por André Meneses Qua Jun 26 2019, 00:59

Uma pergunta: você copiou o código exatamente igual ? Se sim, está faltando a condição do "se" e o "entao" no segundo algorítimo.
Mas de qualquer forma, de fato se o valor inserido for menor  que a variável vazia, esta deve receber o valor digitado. Mas considerando que a variável vazia geralmente é zero, esta não é uma boa solução, a não ser que você garanta que algum valor da entrada será negativo. 

André Meneses
Recebeu o sabre de luz
Recebeu o sabre de luz

Mensagens : 137
Data de inscrição : 12/07/2016
Idade : 20
Localização : Natal - RN

Ir para o topo Ir para baixo

MAIOR e MENOR no visualg Empty Re: MAIOR e MENOR no visualg

Mensagem por isac_pc Sab Jun 29 2019, 23:42

@André Meneses escreveu:
Uma pergunta: você copiou o código exatamente igual ? Se sim, está faltando a condição do "se" e o "entao" no segundo algorítimo.
Mas de qualquer forma, de fato se o valor inserido for menor  que a variável vazia, esta deve receber o valor digitado. Mas considerando que a variável vazia geralmente é zero, esta não é uma boa solução, a não ser que você garanta que algum valor da entrada será negativo. 
Valeu André!! Smile
isac_pc
isac_pc
Recebeu o sabre de luz
Recebeu o sabre de luz

Mensagens : 102
Data de inscrição : 15/05/2016
Idade : 22
Localização : Juazeiro do Norte, CE Brasil

Ir para o topo Ir para baixo

MAIOR e MENOR no visualg Empty Re: MAIOR e MENOR no visualg

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Ir para o topo Ir para baixo

Ir para o topo


 
Permissão neste fórum:
Você não pode responder aos tópicos